Jump to content
Mr.Beer Community
Sign in to follow this  
RaleighBrewer

No Trub?

Recommended Posts

I have made several standard Mr. Beer recipes in the past successfully and in all cases, I have noticed at least some trub in the bottom of the LBK after a couple of days.

For my latest batch, I brewed an Irish Stout about 4 days ago with an OG of 1.070 and US-05 yeast.  Since that time, it has been at high krausen with a lot of activity (foam to the top of the LBK for about 2-3 days) so I know its fermenting, but one unusual thing is that I see almost no trub at the bottom after 4-5 days.  Is there a specific reason this is happening, as every other batch I've brewed has had at least some after the first day or two?

Any insight is greatly appreciated!

Share this post


Link to post
Share on other sites

Because every batch is different.  If you saw krausen, and high activity, you'll be fine.  There will be trub, maybe just less than you're used to.

Share this post


Link to post
Share on other sites
RaleighBrewer said:I brewed an Irish Stout about 4 days ago with an OG of 1.070 and US-05 yeast  Is there a specific reason this is happening, as every other batch I've brewed has had at least some after the first day or two?

Any insight is greatly appreciated!

   If you have seen the krausen, you're fine.  Every batch is different, this is true.  I was sure my first wheat beer was dead because it had so, so much less trub than any I'd ever seen, but it turned out fine.

   Since this is a stout, maybe you just can't see it through the darkness?  I can't remember how US-05 presents itself, since I have only used it once last summer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...