Jump to content
Mr.Beer Community
Sign in to follow this  
LastCall

Yeast cake after fermention is done

Recommended Posts

Just bottled 2 batches and one CAL had a ferm yeast cake. The second Aztec yeast cake was more like slush. Both were in the LBK'S for three weeks. Is this sometimes normal for a yeast cake to not be ferm? This was my first two batches.

Share this post


Link to post
Share on other sites

If you mean "firm", then yes, that's often how it is.  Cold crash for 3 days if you don't want it "slushy".

Share this post


Link to post
Share on other sites

Goes back to the old saying in homebrewing. "Every batch behaves a little different."

Share this post


Link to post
Share on other sites

yeast are living things. living things behave differently. you will seldom get 2 identical fermentations, even with the same yeast.


ive had trub that was as dense as chocolate pudding.. looked like it too! ive had trub that was slushy. . . and everything in between.


 

Share this post


Link to post
Share on other sites

f5875fbe-6eb5-4ffe-87cc-12eb66bd108f.jpg

This is a box stock 2003 Seasonal White IPA in LBK after 21 days of fermentation at a 64-68 degree temperature range.

The debris had been a solid firm film (similar to ice on a lake) prior to removing it from an ice chest and up a flight of stairs to the location I use for bottling.

Firm "Yeast Cake" or STD/infection, what say the Borg? 

Share this post


Link to post
Share on other sites

Sample a little and see how it tastes. If the taste is ok then bottle. As stated by others in this thread all batches behave a little differently. Appearance  is not always a good thing to go by. I've had batches that had more foam, less foam, more trub, less trub, and the beer turned out great.

Share this post


Link to post
Share on other sites

Thanks but it was bottled over two weeks ago with fingers crossed. 

The "password reset" feature on this site has been down a couple weeks, at least for me, tried it daily.

 

I forgot my password long ago and lost the auto login cookie on my computer when I dumped all cookies during a recent cleanup.

The site would not acknowledge my reset request and send an email containing the reset link/token until I tried two days ago.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...