Jump to content
Mr.Beer Community
Sign in to follow this  
ytownmetalhead

Did i SCREW IT UP

Recommended Posts

i have the 8L clear fermenter and just realized that i never put the clips on it --the clips that attach the krausen collar to the fermenter... so there were 2 holes where the clips insert.. did i screw this batch up. I didnt notice it until i added the hops just now.. i did put the clips on now and it has 2 weeks left

Share this post


Link to post
Share on other sites

Someone with more knowledge and experience than me will chime in and give you the proper advice.

 

But it might be you just have to go through the process and see.....and next time attach the clips!

Share this post


Link to post
Share on other sites
51 minutes ago, ytownmetalhead said:

i have the 8L clear fermenter and just realized that i never put the clips on it --the clips that attach the krausen collar to the fermenter... so there were 2 holes where the clips insert.. did i screw this batch up. I didnt notice it until i added the hops just now.. i did put the clips on now and it has 2 weeks left

 

No, it should be fine. The clips are simply there to hold the lid on during high krausen. If you're lid is still on the fermenter, then your beer should be fine.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, ytownmetalhead said:

awesome. thanks a bunch

 

you can close this if you want. i'm not sure how

 

I would, but someone else with the same issue might find this in a search and get the solution they need. ;)

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...